pear install が動かない。

smartyを勉強しようと、ちょっと古めの本を持ってきて付属のCDからPHPの実行環境を構築したが、

require_once("DB.php")

を実行できない。。。というわけで、コマンドプロンプトで、

C:PHP>pear install DB

を実行すると

HTTP error, got response: HTTP/1.1 410 Gone

Didn’t receive 200 OK from remote server, (HTTP/1.1 410 Gone)

と返ってきてインストールできない。

?PEARをインストールし直しても同じ。

グーグル大先生に尋ねると、PEARをバージョンアップしてね音譜と教えられた。

というわけで、ひきつづきコマンドプロンプトから

C:PHP>pear upgrade –force http://pear.php.net/get/PEAR-1.9.0.tar

と実行すると、なにやら先にアップデートしないといけないものが色々あるよと返ってきた。

requires package ‘PEAR’ >= 1.3.3

requires package ‘Archive_Tar’ >= 1.3.1

requires package ‘Structures_Graph’ >= 1.0.2

というわけで、

C:PHP>pear upgrade –force http://pear.php.net/get/PEAR-1.3.3.tar を実施

C:PHP>pear upgrade –force http://peat.php.net/get/Archive_Tar-1.3.1.tar を実施

C:PHP>pear upgrade –force http://peat.php.net/get/Structures_Graph-1.0.2.tarを実施

それから

C:PHP>pear upgrade –force http://pear.php.net/get/PEAR-1.9.0.tar を打つとなにやらいっぱいメッセージが返ってきたが。アップグレードはできたみたい。

これで無事 require_onece("DB.php"); できました。


コメントを残す

CAPTCHA


サブコンテンツ

カレンダー

2017年12月
« 11月    
 123
45678910
11121314151617
18192021222324
25262728293031

アーカイブ

このページの先頭へ